Problem sa Visual Studio 2019

Discussion in 'Programiranje (aplikacije, web dizajn...)' started by kolinsb, May 28, 2020.

  1. kolinsb

    kolinsb Veteran foruma

    Pozdrav raja. Imao sam instaliran Visual Studio 2019. i danas mi je ponudio neki update koji sam (budala) prihvatio. Odmah na početku instalacije update-a je problem nastao kod instalacije WMIProvider komponente i instalacija je pukla. Iz start menija je nestala ikonica Visual Studio 2019 (ostao Blend i ostale komponente). Svi naredni pokušaji da instaliram Studio su bili neuspješni s istim problemom. Uklonio sam ostale komponente Studia kroz kontrol panel, čistio sa CCleaner, ali ništa ne pomaže. Instalacija svaki puta zaglavi s greškom "Microsoft.VisualStudio.Setup.WMIProvider,version=2.6.32.15131' failed to install". Google mi nije ponudio rješenje. Ima li ga netko od vas? :)

    Screenshoot i log su na ovom linku

    https://drive.google.com/drive/folders/1c1EtfZDMJhfVahdTlM7ZmmQuqChNKmph?usp=sharing
     
  2. Qler

    Qler Veteran foruma

    da sam na tvom jestu odradio bih update .net, c# visual framework i onda probao snimit.

    Usput vidi da li ima neki removal tool kao za office paket i za VS...
     
  3. selvin

    selvin Moderator

  4. kolinsb

    kolinsb Veteran foruma

    Rješenje je ispod (kvaka je u tome što pokretanje dole navedenog .msi fajla ne prolazi sa postojećim userom sa admin permisijama, nego sam morao kreirati novog usera i dodati ga u grupu Administrators, i tek tada je instalacija paketa Microsoft.VisualStudio.Setup.WMIProvider.msi prošla, a potom i instalacija Visual Studia, i tom prilikom je instalacija WMIProvider komponente preskočena):


    1. Run install/upgrade from Visual Studio Installer -> FAILED
    2. Open File Explorer and go to the folder which contains Microsoft.VisualStudio.Setup.WMIProvider.msi. (<drive>:\ProgramData\Microsoft\VisualStudio\Packages\Microsoft.VisualStudio.Setup.WMIProvider,version=2.6.32.15131)
    3. Press and hold the Shift key and right-click on the file.
    4. In the context menu, select Run as different user.
    5. Enter the new credentials and click OK to run the msi. -> SUCCEEDED
    6. Run install/upgrade from Visual Studio Installer -> SUCCEEDED
     
    heroic and bhd like this.
  5. Qler

    Qler Veteran foruma

    Ma ja više po default sve tako pokrećem, kao admin posebno... Nije mi palo na pamet da to predložim...

    Sent from my Huawei P30
     
  6. monK

    monK Komšija

    Enable built-in Admin account, i koristiti taj account a ne ove koji nastanu pri instalaciji. Kolikogod bili označeni kao admin, nikada neće biti admin kao ovaj njihov. Ja nakon što sam uveo to u praksu prije 2 godine nisam imao nijedan problem više.